36件の返信, 5人参加 つぶやき Avatar for koro2mogu 1 年前
  • 作成者
    スレッド
  • #488688
    Avatar for koro2koro2
    参加者

    サテラ2を購入したので、NAS(QNAP TS-453Be)への接続を行い録画しようと思いましたが、
    サーバー更新をして一覧には表示されるのですが、接続失敗と出ます。

    色々設定を変えてもつながりません。
    試してみることはありますか?

  • Avatar for mogumogu
    参加者
    @mogu
    : 5,242 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #488690

    koro2さん こんちわ
    NASが見つかるけど接続出来ないということで、まずユーザー&パスワードはちゃんと設定していますでしょうか?

    ユーザー&パスワードをちゃんと設定しているなら、サテラ2自体の不具合が考えられます。初期化256から1032、1054とパッチを当て直してやり直してみましょう。

    それでもダメな場合、かなり高度になりますが、サテラ2内部にアクセスして設定ファイルに直接、NASの情報を設定することになります。
    頑張りましょう。

    私もよくこの事象になりますが、内部ファイルの書き換えで対応しています。

    Avatar for mogumogu
    参加者
    @mogu
    : 5,242 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #488694

    そう言えば、smb1.0は有効化しないとダメかも

    Avatar for koro2koro2
    参加者
    @koro2
    : 115 pt
    #488696

    moguさん返信ありがとうございます。
    ユーザー&パスワードはNASへログインする際のものですかね?それとも共有に関して自分で作成をした権限のユーザー&パスワード
    ですかね?分からないので一応両方やってみましたがダメでした。

    パッチ当て直しもしてみて、smb1.0も有効にしましたが、接続ができません。
    何か他に原因があるのでしょうか?

    Avatar for mogumogu
    参加者
    @mogu
    : 5,242 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #488697

    ここで設定するユーザーとパスワードは、作成したフォルダにアクセスするためのものなので、フォルダをユーザーフォルダにした場合は
    ユーザーのパスワードです、またシステムフォルダの場合は、システムのユーザーとパスワードになります。

    つまり、自分で作成したフォルダの場合はユーザー名があるはずなのでそれを入れる。

    システムが作成したフォルダならユーザーがないのでシステムのユーザーとパスワードです。

    Avatar for koro2koro2
    参加者
    @koro2
    : 115 pt
    #488698

    NASの設定項目をいくつか変えながら試してみても全然つながりませんね。

    >それでもダメな場合、かなり高度になりますが、サテラ2内部にアクセスして設定ファイルに直接、NASの情報を設定することになります。

    とありますが、自分にできるか分かりませんがどのような方法でしょうか?

    それとも、他に確認しておくべき所があるのでしょうか?

    Avatar for mogumogu
    参加者
    @mogu
    : 5,242 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #488699

    まず、NAS以外のフォルダがあったらそれに接続してみましょう。

    それでも出来ない場合

    PCからサテラ2にTelnetでログインして、/DATA/satella.conf
    のファイルを直接編集になるのですが、そのためには
    1、サテラ2のrootログインパスワードの解析
    2、linux標準viエディタの使用方法
    3、実際のパラメーターの編集方法
    が必要になります。

    問題なのが1でコレは「なぜか」自力で探さないとダメと言うことに
    なっています。
    大規模掲示板に方法が書いてありますので参照してください。
    というか、このくらい出来ないと困ると言うことなのかもしれません。
    2はググる
    3はここのフォーラムで設定値は出てきていますので探しましょう。
    申し訳ありませんが、ここに直接書き込むとBAN対象です。
    頑張ってください。

    Avatar for mogumogu
    参加者
    @mogu
    : 5,242 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #488700

    ふと思ったのですが、接続出来ない原因はわかってるんです。

    NASを検索して名前が出ます。
    選びます。
    ユーザーとパスワードを入れます。
    ここまでの情報はsatella.confに反映されます。

    しかし、この次の名称からDNSを使った実IPへの変換が失敗して
    接続出来ないのです。

    なので、自分で設定値を登録すれば接続できる訳です。

    なので事象発生時にDNSの値がどうなっているか、ちゃんと動作してるかが問題で、ここでもDNSを自動取得してるか等のネット自体の問題と、サテラ2本体の問題が発生する訳です。

    修正方法が判っても、では何故?と言われると 自分で作ったものでないのでわからんw と答えるしかなく。
    困ったものです。

    なので初期化してみる、実際の値を入れてみるしかなく
    そのためにはサテラ2のroot権限を取得するしかなくなるわけです。

    rootが取れると良いこともあるよ!
    なんと自分で予約ファイルを弄れるから頭切れ対策ができます。

    Avatar for koro2koro2
    参加者
    @koro2
    : 115 pt
    #488701

    苦戦していますが、何とかsatella.confを観覧するところまでは出来ました。
    もう少し時間がかかりそうです。

    Avatar for mogumogu
    参加者
    @mogu
    : 5,242 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #488703

    おお、そこまで行けましたか、おめです。

    satella.confの設定項目にNFS_~と言うパラメーターがありまして

    本来、4つのパラメーターで構成されています

    path
    user
    password
    addr
    の4つです
    サテラ2でユーザーとパスワードを入れて接続させると3つはセットされていますが
    4つ目のaddrがない状態だと思います。
    そこで、pathと同じ内容をNAS名称から実IPに変換して書き直して追加です。
    NFS_ADDR=”xxx.xxx.xxx.xxx/フォルダ名”
    と追加です。
    xxx.xxx.xxx.xxxはNASのIP
    フォルダ名はpathと同じ名前になります。

    追加したら、ファイルとセーブして

    コマンドでrebootと打ち込めばサテラ2は再起動します。
    再起動後、録画機器にNASが登録され、接続中になっていると思います。
    ガンバです。

    Avatar for koro2koro2
    参加者
    @koro2
    : 115 pt
    #488705

    ここまで出来たのは、moguさんのおかげです。ありがとうございます。

    たしかに、4つめのaddrがないので追加をして保存もしましたが、反映されないです。
    rebootしてから再度rootでログインしてファイルの内容を見る限り変更はされているのですが。

    試しにLAST_CHANNELやLAST_VOLUMEの値を変更してみても反映されていないようです。

    Avatar for mogumogu
    参加者
    @mogu
    : 5,242 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #488706

    おかしい、反映されないのが、謎です。
    ところで、ネットワーク設定でIPの取得方法はグローバルIPの設定になっていますでしょうか?
    また、その時のDNSの値はデフォルトゲートウェイと同じでしょうか?

    Avatar for koro2koro2
    参加者
    @koro2
    : 115 pt
    #488707

    NFSで始まるものがもう1つあるみたいですが、NFS_MOUNT_ON_BOOT=0というのは関係ないんですよね。

    Avatar for mogumogu
    参加者
    @mogu
    : 5,242 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #488708

    NFS_ADDR=//192.168.0.100(IPアドレス)/接続先のディレクトリ

    でした、フォーマットは大丈夫?

    Avatar for mogumogu
    参加者
    @mogu
    : 5,242 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #488709

    bootは関係ないです

    Avatar for koro2koro2
    参加者
    @koro2
    : 115 pt
    #488710

    ipの値はOKだと思います。
    NFS_ADDR=の値もNASのアドレスを設定しました。
    そうなると、怪しいのは接続に関してですかね?ルーターとかハブとかかな?

    Avatar for mogumogu
    参加者
    @mogu
    : 5,242 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #488711

    サテラ2がちゃんとIPを貰えているか確認してみましょう。

    正常なら、IP、サブネットマスク、デフォルトゲートウェイ
    正副のDNSがちゃんと入っていると思います。

    Avatar for koro2koro2
    参加者
    @koro2
    : 115 pt
    #488712

    確認しましたら、すべての欄は埋まっています。
    一応書きますと、有線LAN、グローバルIPを選択
    ipアドレス10.0.0.24 サブネット255.255.255.0
    ゲートウェイと優先代替DNSは10.0.0.1でした。
    接続成功と出てはいます。

    サテラとLANは同じハブにつながっていますが、
    全体のLANの構成を確認した方がいいですかね?

    Avatar for mogumogu
    参加者
    @mogu
    : 5,242 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #488713

    IPがダメですw
    内部IPの基本がダメです。
    192.168.xxx.xxxとしないとダメですw

    きっとそれが原因です

    Avatar for mogumogu
    参加者
    @mogu
    : 5,242 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #488714

    プライベートIPアドレスで検索してみましょう。
    192.168.xxx.xxxは基本で決まっている値なのでそれ以外を利用してはいけません。

    Avatar for mogumogu
    参加者
    @mogu
    : 5,242 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #488715

    10.xxx.xxx.xxxは大規模用なので普通の家庭用には使いません
    民生品では考えてもいないと思います。
    なのでどの様な動きをするか分かりませんので注意が必要です。

20件の返信を表示中 - 1 - 20件目 (全36件中)
  • このトピックは作成者が解決マークにしたため返信は締め切られています。もしあなたが解決できないなら、新しくトピックを作成してください。