10件の返信, 2人参加 つぶやき mogu 6 月前
  • 作成者
    スレッド
  • #501563
    tomomi
    参加者

    CentOS7.6.1810 で、samba を導入しています。
    Window10からはCentOSのファイルサーバーのフォルダに読み書きできます。
    サテラ2 1504 で、NASを検索するとCentOSのフォルダは見つかるのですが、
    接続しようとすると”接続失敗”となります。
    そこで、サテラ2 にrootでログインして、
    mount -t cifs -o username=ユーザ,password=パス,rw,iocharset=utf8,domain=ドメイン //192.168.0.6/nas /SAMBA
    を実行したところ、
    mount error 13 = Permission denied
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    が返ってきます。
    ちなみに、nasne に同様の処理を実行したところ、
    接続され、/SAMBAフォルダも有効になりました。
    CentOSのsambaの設定に問題があるように思い、アクセス権等をいろいろと試しましたが、
    接続に至っていません。
    是非、ご教授下さい。
    よろしくお願いします。

  • 上げ
    Up
    0
    Down
    下げ
    mogu
    参加者
    @mogu
    : 4,397 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #502307

    あ・・・ごめんなさい satella.confでしたか・・・うろ覚えで(–;
    とりあえず、そのファイルでサテラの環境は管理されていますので該当ファイルを修正してみてください、削除の必要はありません。

    直しても、接続できないのはnas接続環境が壊れているのですが、一応、ほかの機器に接続してみて成功するようであれば、接続するための環境はちゃんと出来ているので、satella.confのNFS_~の内容を実際ほしい内容に変更するだけなのですが、接続機器を探してみつかるのはネットワークのマスターブラウザーを検索して表示するためで、ユーザー&パスワードを設定しても接続不可なのは、satella.conf上のNFS_PASSの名前から、NFS_ADDRの実ipを求められないからです。(この状況を環境が壊れていると表現しています)。
    このパラメーターを設定することにより接続可能なハズですが、環境が壊れているので無理な場合、256パッチの出番になるわけです。
    では、ほかの接続先に接続できる=環境はちゃんと動くことになりますので
    強制的に上書きしてターゲットの接続先に変えてしまえばいいわけです。

    また、サテラは古い規格で動いているためsmbが1.0のみサポートです。
    linuxでsmb1.0が有効なのか確認してみてください。

    上げ
    Up
    0
    Down
    下げ
    mogu
    参加者
    @mogu
    : 4,397 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #502250

    sambaが予約語です。 コマンドの
    utf8がいらない、ドメインもいらない。
    でも、マウントしても意味がないので
    /DATA/satella2.confの中身でNFS_~の値を接続先に変更してみましょう。
    それでも接続できない場合は、環境が壊れている可能性があるので、接続先を別のところに変更して接続できるか、接続できるのであればsatella2.confの中身を編集。
    場所を変えても接続できない場合は、256パッチからパッチを入れ直して接続できるか試してみてください。

    上げ
    Up
    0
    Down
    下げ
    mogu
    参加者
    @mogu
    : 4,397 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #516813

    お疲れ様です。
    Windows10は初期状態ではsmb1.0は有効化されていません、Windows機能の追加でsmb1.0をインストールしないと使えません。

    また、256パッチは入れたことで購入時に戻る「だけ」ですのでそこから1055パッチを入れ直さないとダメです。

    ガンバです

    上げ
    Up
    0
    Down
    下げ
    tomomi
    参加者
    @tomomitouda
    : 38 pt
    #502343

    mogu 様
    情報、どうもありがとうございます。ご指摘のように”smb1.0″ が原因のようです。
    それで、mount の secオプションを none にし、
    # mkdir /nas
    # mount -t cifs //192.168.0.6/satella /nas -o sec=none
    を実行すると、 /nas に共有できました。
    それで、satella.conf に、mount情報(NFS_ADDR,NFS_PATH,NFS_ID=,NFS_PWD)を入力してみましたが、
    “接続失敗”となってしまいます。
    また、直mountコマンドで、マウントポイントを /nas から /SAMBA に変えてみましたが、
    録画ボタンを押すろ”録画機器が無い”旨のエラーがでます。
    現状では、
    1) サテラ2の録画機器の選択で、nasneを接続しておき、
    2) 上記のコマンドでmountした /nas を /SAMBA にシンボリックリンクする
    ようにして、対応しています。

    satella.conf でなんとかならないかどうか
    CentOSのsambaの設定をいじるか
    で試してみたいと思います。

    なにか情報がありましたら、よろしくお願いいたします。

    上げ
    Up
    0
    Down
    下げ
    tomomi
    参加者
    @tomomitouda
    : 38 pt
    #502289

    mogu 様
    ご回答、ありがとうございます。
    /DATA/の下には satella.conf しかなのですが、 satella2.conf で良いでしょうか?
    その場合、satella.conf は削除した方が良いでしょうか?
    一応、satella.conf の内容は添付のようにしましたが、
    [attachment file=”キャプチャ.JPG”]
    接続できませんでした。

    これがダメなら、256パッチで実験してみます。

    上げ
    Up
    0
    Down
    下げ
    tomomi
    参加者
    @tomomitouda
    : 38 pt
    #516823

    mogu 様
    結論から申し上げるとLinuxサーバーにmountできました。
    色々と実験した結果、CentOSではダメで、ubuntuでOKとなりました。

    方法ですが、
    事前に、satella.conf と server_list.txt に IPアドレスを設定します。
    次に
    cd /DATA
    cp /APP/usr/bin/samba.sh .
    を実行し、/DATA 下で作業します。
    Linux(samba)のバージョンによって、
    samba.sh の mount オプションに sec=none を付けるように samba.sh を修正します。
    “接続中”画面で、./samba.sh connect //192.168.0.6/satella
    を実行すると、Linuxサーバーに接続できて、録画もできるようになりました。
    CentOS7.xでは接続はできるのですが、数分で画面が固まってしまいます。
    ubuntu は、16.04,16.10,18.04 (samba 4.3.11,4.5.5,4.7.6) で試しましたが、
    途中で固まることはありませんでした。

    とりあえずこれで、録画環境を整えることができますので、
    次のアップデートで smb 2.0以上 に対応してくれることを期待したいと思います。

    mogu 様、お付き合いどうもありがとうございました。

    上げ
    Up
    0
    Down
    下げ
    mogu
    参加者
    @mogu
    : 4,397 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #502351

    tomomiさん
    とりあえず、一歩前進でよかったです。

    /nasでマウント出来たと言うことなので、smb1.0での接続は出来ると言うことになると思います。

    では、次にやることは192.168.0.6以外の所に接続できるかです。
    windows pcで「smb1.0を有効化」して、共有フォルダを作成して接続できるか試してみましょう。
    接続できればsatella.confの内容をターゲットに変え、接続できなければ256パッチで初期状態にもどしましょう。

    私も、同様な状況になった場合にはルーターにある簡易nas機能を使い、簡易nasに接続してsatella.confを修正してrebootすることで回避しています。
    がんばです

    上げ
    Up
    0
    Down
    下げ
    tomomi
    参加者
    @tomomitouda
    : 38 pt
    #502290

    satella.conf を抜粋した写真が上手く添付できていませんでした。
    ———-satella.confの抜粋———-
    UPDATE_SERVER=http://sukapapa.net
    SUBTITLE=0
    TUNER_TYPE=1
    UPNP_ONOFF=0
    SERVER_SAFE=0
    EPG_CNT=3
    NFS_ADDR=//192.168.0.6/satella
    NFS_PATH=//XSERVER/satella
    NFS_ID=USERNAME
    UPDATE_SERVER_ID=s2
    UPDATE_SERVER_PWD=31082
    NFS_PWD=PASSWORD
    AUTOLOCK_ADULT_CH=TRUE
    ——————–

    上げ
    Up
    0
    Down
    下げ
    mogu
    参加者
    @mogu
    : 4,397 pt
    サットグループ賞アンテナマスターサットフォーラム賞誕生日プレゼント賞紹介ビジター賞
    #517071

    接続おめですw
    楽しいサテラライフをお楽しみください。

    上げ
    Up
    0
    Down
    下げ
    tomomi
    参加者
    @tomomitouda
    : 38 pt
    #516464

    やっと返信できるようになりました。satchのホームページ不安定ですね。

    Windows10 のフォルダを共有させて、
    サテラ2の「録画機器の選択」から黄色ボタンを押して、NASを検索させましたが、
    Windows10 で共有させたフォルダを見つけることはできませんでした。
    Windows10 の情報を表示させてみると

    C:\WINDOWS\system32>sc.exe qc lanmanworkstation
    [SC] QueryServiceConfig SUCCESS

    SERVICE_NAME: lanmanworkstation
    TYPE : 20 WIN32_SHARE_PROCESS
    START_TYPE : 2 AUTO_START
    ERROR_CONTROL : 1 NORMAL
    BINARY_PATH_NAME : C:\WINDOWS\System32\svchost.exe -k NetworkService -p
    LOAD_ORDER_GROUP : NetworkProvider
    TAG : 0
    DISPLAY_NAME : Workstation
    DEPENDENCIES : Bowser
    : MRxSmb20
    : NSI
    SERVICE_START_NAME : NT AUTHORITY\NetworkService

    Windows10 は、DEPENDENCIES をみると、smb2.0 のようです。

    この時、サテラ2で、smbtree を実行したところ、
    次のような結果となりました。

    WORKGROUP
    \\SERVER Samba 4.8.3
    \\SERVER\IPC$ IPC Service (Samba 4.8.3)
    \\SERVER\satella
    \\SERVER\print$ Printer Drivers
    \\WIN10
    cli_rpc_pipe_open: cli_nt_create failed on pipe \srvsvc to machine WIN10. Error was NT_STATUS_ACCESS_DENIED
    \\NASNE Samba
    \\NASNE\IPC$ IPC Service (Samba)
    \\NASNE\nasne_home
    \\NASNE\share1

    次に、256パッチを試そうと patch をあてたのですが、
    GUIが1054とは異なっていて、使い方がよくわからず の状態です。

    おつきあい、ありがとうございます。
    また、よろしくお願いします。

10件の返信を表示中 - 1 - 10件目 (全10件中)
  • この質問をすべて閲覧、また質問や回答をするにはメンバー登録をしてログインしてください。新規登録ボタンはページの一番上にあります。